Unable to reproduce global melt cookbook results in the ASPECT manual

Hi everyone,

I am unable to reproduce the global melt cookbook models (as shown in the ASPECT manual) for recent versions of ASPECT. I have tried and failed to reproduce these results using the virtual machine image (ASPECT 2.5.0-pre and deal.II 9.4.0) as well as my native Linux install (ASPECT 2.4.0-pre and deal.II 9.3.3). I was successful previously in a much older version of ASPECT that I once had installed (version 2.0.1 and deal.II 9.0.1).

Note that I have made no changes to the input parameter files. I am simply trying to rerun these cookbook models and reproduce the results shown in the manual. Is anyone else able to successfully reproduce the global melt (with melt) cookbook models?


Hi Micah,
I am not an expert in the melt models, but could you specify what you mean when you say “unable to reproduce”? Melt models are highly nonlinear and so very small changes in our algorithms can lead to large differences over the model runtime. So if your downwellings and upwellings and melt regions are simply in different places at different times that could be just a consequence of updates to our algorithms. If however the model crashes, or you dont see melt at all that would be reason for concern and we could discuss how to look deeper into the issue.


@gassmoeller I am already on this, I should have let you know. I can reproduce that the model is not just different (is has oscillations as visible in Micah’s previous post), but it also crashes. I think what might have changed the behavior of this model after I wrote the cookbook was our change in how we compute the artificial diffusion, specifically at the boundaries (i.e. the improvement you added for the artificial viscosity). For Micah: In order to not get over- and undershoots in the temperature, ASPECT adds a small amount of artificial diffusion in the places where it is necessary. We modified this routine a few years ago and now add less artificial diffusion than before (which is more accurate). This makes a particularly large difference in models that have a very coarse resolution, like this cookbook. Since we now have less diffusion than before, the plumes are smaller/thinner/not as hot, and in this particular case, they are not properly resolved and at some point the model crashes.

I am trying to update the setup, one thing I tried was simply increasing the resolution, but then I did not get melt any more because the plumes were much colder than before. So I’ve started to play around with some other parameters and hopefully will have an update soon.

Hi Micah,

I think this should fix it:

Best regards,