Restart causes error in deal.ii, file

Hi all,
I’ve run into a problem when restarting a model, and I received the following error message:

An error occurred in line <2661> of file </ddn/data/dgl6jv1/Progs/git/dealii-v9.3.1/tmp/unpack/deal.II-v9.3.1/source/distributed/> in function
void dealii::parallel::distributed::Triangulation<dim, spacedim>::execute_coarsening_and_refinement() [with int dim = 2; int spacedim = 2]
The violated condition was:
Additional information:
This exception – which is used in many places in the library –
usually indicates that some condition which the author of the code
thought must be satisfied at a certain point in an algorithm, is not
fulfilled. An example would be that the first part of an algorithm
sorts elements of an array in ascending order, and a second part of
the algorithm later encounters an element that is not larger than the
previous one.

There is usually not very much you can do if you encounter such an
exception since it indicates an error in deal.II, not in your own
program. Try to come up with the smallest possible program that still
demonstrates the error and contact the deal.II mailing lists with it
to obtain help.


#0 /ddn/data/dgl6jv1/Progs/git/dealii-v9.3.1/deal.II-v9.3.1/lib/ dealii::parallel::distributed::Triangulation<2, 2>::execute_coarsening_and_refinement()
#1 ./aspect_20210818: aspect::Simulator<2>::refine_mesh(unsigned int)
#2 ./aspect_20210818: aspect::Simulator<2>::maybe_refine_mesh(double, unsigned int&)
#3 ./aspect_20210818: aspect::Simulator<2>::run()
#4 ./aspect_20210818: void run_simulator<2>(std::__cxx11::basic_string<char, std::char_traits, std::allocator > const&, std::__cxx11::basic_string<char, std::char_traits, std::allocator > const&, bool, bool, bool)
#5 ./aspect_20210818: main

Here, I tried to use the latest deal.ii and aspect versions to see if that makes a difference, but running the model with deal.ii v9.2.0 and an older aspect version gave the same error. Before trying to create and send over the smallest possible model that still produces this model, does anyone have an idea what to do or try, or is there something obvious that I am doing wrong?

Many thanks for any suggestions,


Is the snapshot taken with the same ASPECT and deal.II version that you use to restart?

Yes, both initial run and restart are run with the same, latest deal.ii and ASPECT versions.

Alright, then a simple prm that shows the problem would be great to have.