Dealii error when running 3d cartesian model

Dear dealii and AEPECT developers,

I ran into an error when I tried to run a 3d cartesian model with one compositional field and a background field.

-- For information on how to cite ASPECT, see:
Number of active cells: 442,368 (on 5 levels)
Number of degrees of freedom: 18,526,806 (10,839,459+461,041+3,613,153+3,613,153)

An error occurred in line <507> of file </tmp/unpack/deal.II-v9.5.1/source/fe/> in function
    dealii::CellSimilarity::Similarity dealii::MappingCartesian<dim, spacedim>::fill_fe_values(const typename dealii::Triangulation<dim, spacedim>::cell_iterator&, dealii::CellSimilarity::Similarity, const dealii::Quadrature<dim>&, const typename dealii::Mapping<dim, spacedim>::InternalDataBase&, dealii::internal::FEValuesImplementation::MappingRelatedData<dim, spacedim>&) const [with int dim = 3; int spacedim = 3; typename dealii::Triangulation<dim, spacedim>::cell_iterator = dealii::TriaIterator<dealii::CellAccessor<3, 3> >; typename dealii::Mapping<dim, spacedim>::InternalDataBase = dealii::Mapping<3, 3>::InternalDataBase]
The violated condition was: 
Additional information: 
    You are using MappingCartesian, but the incoming cell is not

#0  /home/qxl51/dealii-9.5.1-toolchain-openmpi-4.1.5-mpi-io/deal.II-v9.5.1/lib/ dealii::MappingCartesian<3, 3>::fill_fe_values(dealii::TriaIterator<dealii::CellAccessor<3, 3> > const&, dealii::CellSimilarity::Similarity, dealii::Quadrature<3> const&, dealii::Mapping<3, 3>::InternalDataBase const&, dealii::internal::FEValuesImplementation::MappingRelatedData<3, 3>&) const
#1  /home/qxl51/dealii-9.5.1-toolchain-openmpi-4.1.5-mpi-io/deal.II-v9.5.1/lib/ dealii::FEValues<3, 3>::do_reinit()
#2  /home/qxl51/dealii-9.5.1-toolchain-openmpi-4.1.5-mpi-io/deal.II-v9.5.1/lib/ dealii::FEValues<3, 3>::reinit(dealii::TriaIterator<dealii::CellAccessor<3, 3> > const&)
#3  /home/qxl51/dealii-9.5.1-toolchain-openmpi-4.1.5-mpi-io/deal.II-v9.5.1/lib/ double dealii::GridTools::volume<3, 3>(dealii::Triangulation<3, 3> const&, dealii::Mapping<3, 3> const&)
srun: Job step aborted: Waiting up to 62 seconds for job step to finish.
#4  /group/rudolphgrp-mpi-io/qxl51/./aspect: aspect::Simulator<3>::run()
#5  /group/rudolphgrp-mpi-io/qxl51/./aspect: void run_simulator<3>(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, bool, bool, bool)
#6  /group/rudolphgrp-mpi-io/qxl51/./aspect: main

This error only appears when the model is run in debug mode, and 2d cartesian models with a similar setup ran with no problem in ASPECT. Could anyone help to figure out what might be the issue?

For more content, here’s the input file that I used:
original.prm (6.3 KB)


Hi Lucy,

I can’t recreate your issue using deal.ii 9.5.2 and mainline ASPECT. I doubt it’s a deal.II problem (the differences between 9.5.1 and 9.5.2 are very small - Releases · dealii/dealii · GitHub).

A couple of questions:

  • Which version of ASPECT are you using?
  • Do you still have a problem when you set X, Y, Z repetitions = 2, Initial adaptive refinement = 2 and Initial global refinement = 1? Your problem is too big to efficiently test.

Best wishes,

Hi Bob,

Thanks for checking my input file! I am using ASPECT-2.6.0-pre with deal.II-v9.5.1. I tried to reduce the repetitions to X, Y = 2 and Z = 1 as you suggested and the error went away without changing anything else.