Pylith Installer Problems

I tried to use the pylith installer to build on a cluster, and locally, and got the same error during config:

checking for python module six... configure: error: in `/home/dockimble/pylith_ii':

I have included the config.log from the attempted run.

Configure flags were:


export SITE=pwd


I don’t see any config.log.

When you run configure for the installer, you should check to make sure you are having the installer build all of the Python dependencies (setuptools, cython, six, numpy, cftime, h5py, netcdfpy). I will fix the configure so that this happens automatically.

Also, don’t you want the installer to build the knepley/feature-petcs-fe branch instead of master (master requires an older version of PETSc knpley/pylith than the current one).

config.log (39.9 KB)

There it should be. And yes, I do want it to build the knepley/feature-petsc-fe branch. Thank you.

I have pushed changes to the PyLith installer (branch baagaard/feature-update-dependencies) to insure all Python packages are built when building Python (–enable-python). This should resolve the problem you have in not building some of the Python packages (like six; which is the error you are getting).

You misspelled openssl as oenssl in the file.

Arrrrgh! Fixed and pushed.

I am going to continue the thread so that future users of this tool will be able to reference.

Using the following configure parameters:

export SITE=pwd


The install process has continued until hitting a snag at h5py.

Log included: make.log (9.9 KB)

What cython is being used?

If the installer isn’t building it, i don’t believe it is there.

I need you to provide more information and dig deeper. Did the installer build cython? If not, then pull the installer again, wipe the installer build directory clean, and reconfigure. If so, then double check that that installer cython is the one in the path. If it is failing, then I need to know which operating system you are using and what compilers.

Good news,

It would appear as if the installer worked correctly (this would be the first time it ever has for me).

My machine is running Ubuntu 20.04, config and make logs are included.


config.log (41.7 KB) (529.8 KB) (make.log is a 10+MB text file)