Error installing Pylith on Ubuntu 20.04 with conda enviroment


I’m trying to install Pylith from source using pylith-installer-2.2.1-1.tgz with this configure parameters

$ $HOME/src/pylith/pylith-installer-2.2.1-1/configure --enable-openssl --enable-mpi=openmpi --prefix=$HOME/pylith

and I’m getting the next error when testing the installation
pylith-installation-log.txt (17.9 KB)

I’m using a clean conda enviroment.


I believe the error you are getting was a known bug in the slipdir test for PyLith v2.2.1. Please try running some of the examples to verify PyLith is installed correctly. Note: PyLith v2.2.2 should pass all of the tests.

I see that OpenMPI detected another network interface. Is this a cluster? If so, you should be using the MPI installed by the system administrator to ensure MPI is configured for the cluster hardware.

When I do the exactly same steps with Pylith v2.2.2 I get this error
error_log_Pylith2.2.2.txt (10.4 KB)
which I posted before in another entry but I couldn’t fix the error, that’s why I tried the v2.2.1.

I run 2d/subduction/step01.cfg with no errors, I don’t understand what I’m doing wrong with Pylith v2.2.2.

As this is my first try compiling this code, I’m doing it on my machine, so could it be the --enable-mpi=openmpi the reason that I’m getting this another network interface detected? If that it’s the case, how can I make sure that I’m using the MPI installed by system administrator?

The installer for v2.2.2 uses newer versions of some of the dependencies. The Python NetCDF4 package adds a dependency on cftime. For some reason, there is a problem installing it. The workaround is to install cftime manually. However, there are very few changes from v2.2.1 to v2.2.2, so it is probably easier to just use v2.2.1.

Ask your system administrator if MPI is installed and how to make sure it is in the environment path. When running the installer configure script, rather than have the installer install MPI, set the compilers to the MPI compilers for your system. For example, use CC=mpicc CXX=mpicxx if the MPI compilers are mpicc and mpicxx for C and C++, respectively.