Pylith runtime error OSX


#1

Hi,

After reinstalling Pylith on a new (OSX) laptop I’m getting the following run-time error (running, e.g., pylith step01.cfg in the suggested 3d/hex8 folder):

File “/Users/moortgat/pylith/bin/pylith”, line 25, in <module>

from pylith.apps.PyLithApp import PyLithApp

ImportError: No module named pylith.apps.PyLithApp

Even previously installed versions seem to now generate this error. Is this perhaps a simple path or environment setting?

The configure log and last ~8000 lines of output from make are attached. The latter ends with what looks like a PETSC related error in running the test suite at the end of installation. The referenced log from (tests_auto/2d/tri3) is attached.

I’d appreciate any suggestions.

Best,

–Joachim


Joachim Moortgat
Assistant Professor
School of Earth Sciences
the Ohio State University
275 Mendenhall Lab, #303
125 South Oval Mall
Columbus, OH 43210
http://u.osu.edu/moortgat/

config.log (42.0 KB)
makefile_endoflog.txt (1.1 MB)
test-suite.log (38.3 KB)


#2

The make log is fine. All tests pass except that automated test, but nothing ran there at all, so I suspect some files are missing.

The error you get when running suggests you do not have the PYTHONPATH set to the install directory. Where did you have it install? What is your PYTHONPATH?

Thanks,

Matt

#3

The error message is in the test-suite.log (where you would expect to find it):

...
[0]PETSC ERROR: No support for this operation for this object type
[0]PETSC ERROR: Mesh partitioning needs external package support.
Please reconfigure with --download-chaco.
...

The config.log shows you asked the installer to configure PETSc with --download-chaco, so it looks like PyLith is not finding the correct PETSc. It is not clear what you mean by even previously installed versions failed if you are using a new laptop.

My guess is that your environment is not setup consistently. You need to insure that your environment does not point to any PyLith or its dependencies installed previously or installed by other software. You also need to make sure that AFTER running the PyLith configure but BEFORE running make that you run “source setup.sh” or the equivalent for setting up your environment.


#4

Looks like it was indeed an issue with path settings. I figured it out.
Thanks for your help.