How to run cookbook "fastscape_eroding_box.prm"?

I found there is a cookbook can link FastScape and ASPECT, it’s interesting and I’d like to run this .prm file.
But I found that, although there is aspect-main/source/ source code, the answer also is “There is no such subsection to be entered: Mesh deformation.Fastscape”.
I think it’s because that the file doesn’t be complied, so I copy the “ and fastscape.h” as plugin. But it has the same answer “There is no such subsection to be entered: Mesh deformation.Fastscape”.

Can anyone tell me how to run the fastscape_eroding_box.prm in cookbook folder(aspect-main version)?

Hi Qyunian,
I sent the installation instructions by email as well, but I thought it would be useful to post it here as well until I can add documentation on installing/using the coupling.

  1. The following needs to be exported in .bashrc for fastscape visualization to work. Though, I am not sure if this needs to be done every time or only during installation. If this is not set, the models will still work but the VTK files will not show anything when opened in paraview.

export GFORTRAN_CONVERT_UNIT=‘big_endian’

  1. Clone fastscape from my github branch. This includes the file that writes fastscape visualizations within the aspect model folder.

git clone

  1. Build fastscape so that it creates a shared library (.so) file for ASPECT to link to:

cmake -DBUILD_FASTSCAPELIB_SHARED=ON /path/to/fastscape

  1. Install ASPECT with a flag to tell it to link to ASPECT and where the .so file is:


-DFASTSCAPE_DIR=/path/to/fastscape/build \


On a side note for visualization, fastscape VTK’s will not be written with a time and can’t be immediately shown on top of ASPECT in paraview. For this, in contrib/fastscape there is a python file, you can run this within the model folder and it should convert the .vtk to .vts files which include the same visualization timings as ASPECT. Although, looking through that file, in lines 48 and 148 it still points to a VTK folder whereas now the files are written in a fastscape folder so those two lines would need to be updated.

Hi Derek,

Many thanks to your help, it’s going well. you are so friendly and professional.

But I also have some trouble, that is after I rewrite topography.vtk as topography.vts and topography.pvd successfully. I also can’t visualization topography by opening topography.pvd in Paraview. I don’t know how to deal with it.

Here is my output ./fastscape with topography.pvd, topography.vtk, topography.vts.
Looking forward to you. (5.0 MB)

I ran a test, and it seems that

export GFORTRAN_CONVERT_UNIT=‘big_endian’

does need to be set in the terminal before running a job otherwise the visualization won’t show. Could you add the line to your .bashrc and make sure it is loaded by using the command:


If this says big_endian, could you try again and see if the visualizations work?

Hi Derek,

Thanks to your patient answer.
I did add the “export GFORTRAN_CONVERT_UNIT=‘big_endian’” into my .bashrc file. And “echo $GFORTRAN_CONVERT_UNIT” command did show “big_endian”.
And I get the topography.vtk successfully. But after I convert topography.vtk to topography.vts, Paraview also can’t show this file. I don’t know why.
what do you think of Can it be the problem of my Paraview version(5.11.1 with python3.9) or Python(3.9.6)?
If it’s possible, could you send your eroding_box topography.vtk output for me? I’d like to know whether it’s the problem of my