Get help with parameter-GUI installation

Dear all,

I was trying to install the parameter-GUI follow the ASPECT munal. I have generated the ‘parameter-GUI’ executable but I did not have the ‘aspect-gui’ script which was mentioned in the munal.

So, I have no idea about How to edit parameter files with parameter-GUI. Because when I open the executable I found that the software can only open the .xml files. But the parameter files which be used to start an ASPECT model are all .prm files.

Many thanks for any suggestion.


You need to configure ASPECT with cmake and make sure it find the gui program. You can do

   export PARAMETER_GUI_DIR=/home/bob/bin/

(of course replace it with the path where the GUI is) or

  cmake -D PARAMETER_GUI_EXECUTABLE=/path/to/parameter_gui .

This should create the script aspect-gui in the build directory. Launch that and you can open .prm files.

1 Like

I cmake aspect code after build parameter.gui by command

cmake -DPARAMETER_GUI_DIR=/home/bob/bin/ -DDEAL_II_DIR=/u/username/deal-installed/

then build aspect-gui and run it
screen showed a error window (massage)

Parse error in file temp.xml
Cannot convert boolen type to boolean Line 645 column 22176

I clicked “ok”

and I found I have the same question as same as @dongmiao

aspect-gui can save as prm file but open xml only


some SECTION parameter are loss in the aspect-gui template

like “Boundary composition model, Geometry model, Gravity model…etc”

I wonder if I didn’t compile parameter-gui completely or which step I made wrong command @@"

but I checked the step with manual I still confused @@"

I’m sorry , disturb to you!

Hi Miao,
were you able to create the aspect-gui following Timo’s suggestions?

@cgw0814: You did nothing wrong, but I think you found a bug in the parameter gui that we did not know. I opened a pull request to fix it (see If you want to test it yourself you can update your parameter gui once the pull request is merged, and I also attach a patch that shows how to modify the parameter gui yourself if you do not want to wait:

diff --git a/xml_parameter_reader.cpp b/xml_parameter_reader.cpp
index a5b6b6d..fc2e5b4 100644
--- a/xml_parameter_reader.cpp
+++ b/xml_parameter_reader.cpp
@@ -217,7 +217,7 @@ namespace dealii
                   QRegExp  rx_string("\\b(Anything|FileName|DirectoryName|Selection|List|MultipleSelection)\\b"),      
-                           rx_bool("\\b(Selection true|false)\\b");
+                           rx_bool("\\b(Bool)\\b");
                   // store the type "Anything" or "Filename" as a QString
                   if (rx_string.indexIn (pattern_description) != -1)

I really appreciate for your help. When I enter the command
cmake -D PARAMETER_GUI_EXECUTABLE=/mnt/parameter_gui-master/bin/parameter_gui .
screen showed
– Configuring done
– Generating done
– Build files have been written to: /mnt/parameter_gui-master
but I did not find the script aspect-gui in “/mnt/parameter_gui-master”.

Sorry to bother you!

Hello Dr. gassmoeller,

Thanks for your reply. I have create the aspect-gui. The only trouble is that it can only open xml files like @cgw0814 said. But the SECTION parameter like “Boundary composition model, Geometry model, Gravity model…etc” are present in the template.

Just to be sure, you did this in the ASPECT build directory, right? Did ASPECT report that it found the gui (you can post the detailed.log in the folder)?

Thanks for your suggestion. I have find aspect-gui in home/ubuntu/bin/. I can open it with the parameterGUI and it shown the temp.xml*. It seems to be no problem.
The only trouble is that it can only open xml files like @cgw0814 said. The difference with @cgw0814 is that the SECTION parameter like “Boundary composition model, Geometry model, Gravity model…etc” are present in the template.

Yes, the aspect-gui had build successfully

but the problem related to opening file-type still exist in aspect-gui as @dongmiao said

thanks @gassmoeller kindly reply us

it’s very helpful.

By the way,
the more than one question is how do I save the default option in the aspect-gui


Use year in output instead of seconds = true

if I select true, this option could not add automatically in the prm, it need to switch false and modify in the saved prm file


I think what you want is currently not implemented in the aspect-gui. You can use it this way:


if you want to create (save) a new .prm file, or this way:

aspect-gui one_of_your_existing_parameter_files.prm

if you want to modify and save an existing .prm file. You can currently not open an existing .prm file directly from the program, and it would be very complicated to implement that. The reasons are complex, if you want to work on this, I can give you further advice, but the two examples that I wrote above should allow you to do everything you need (create a new .prm file, or modify an existing .prm file). You just need to close the aspect-gui and reopen it, if you want to read a new file.

@cgw0814: You are right in your last comment, every default parameter is not written in the .prm file. This is on purpose, because if the parameter is not in the file, ASPECT will use its default value. I.e. there is no reason for you to write

Use year in output instead of seconds = true

because ASPECT will assume it anyway if you do not set it to false. If we would write all default values, the .prm file would have hundreds of lines.