Problem running example


I’m new to Pylith and I recently downloaded Pylith 4.0. I was going through the instructions in the document to run “box-2d” but I’m having problems running step01 with an error related to perhaps, petsc. I have the same problem with the other examples that I’ve tried. Below is the last few lines of the error message.

ImportError: dlopen(/Users/chongjh11/Downloads/pylith-4.0.0-macOS-10.15-x86_64/lib/python3.10/site-packages/pylith/utils/, 2): Symbol not found: __ZTTNSt3__119basic_ostringstreamIcNS_11char_traitsIcEENS_9allocatorIcEEEE
  Referenced from: /Users/chongjh11/Downloads/pylith-4.0.0-macOS-10.15-x86_64/bin/../lib/libpetsc.3.020.dylib (which was built for Mac OS X 13.0)
  Expected in: /usr/lib/libc++.1.dylib
 in /Users/chongjh11/Downloads/pylith-4.0.0-macOS-10.15-x86_64/bin/../lib/libpetsc.3.020.dylib

I downloaded using the example “curl -L…” for a Mac, and did the “source” before running the examples. I’m using MacOS 11.3.1 to run all the Pylith examples.

I can provide more information about the error if needed too! Thanks in advance!

What type of processor does your computer have? arm64 (Apple M1,2,3) or x86_64 (Intel)? This information is available in “About this Mac”. The binary you downloaded is for a mac with an Intel x86_64 processor, not the newer Apple M arm64 processors. If you have an arm64 processor, please try the binary for the arm64 processor.

I intended to build the binary for macOS 10.5 and later, but there may have been a problem setting up the build as the error message may suggest that it was built only for macOS 13 and later.

Hi Brad, thanks for the quick response! I have the x86_64 Intel chip. Should I try building from source instead, or is there another option?

I will look at the binary package and will try regenerating it to support older macOS versions.

I have verified that both macOS binary packages for v4.0.0 are built for macOS 13 (not the intended 11.0 for arm64 and 10.15 for x86_64). I am working on this and expect to post updated binaries on Monday Feb 5.

New binaries for v4.0.0 for macOS x86_64 and arm64 are now available. See PyLith v4.0.0 released - #2 by baagaard.

Hi Brad, thank you so much for your help on this! It works now!