Error when creating cohesive cells for 2D mesh generated using LaGriT


#1

Dear all,

I am building a simple 2D mesh with a reverse fault dipping 45 degrees using LaGriT. In building it, I started from the example I found in 3d/tet4 and I rotated the fault from a strike-slip to a reverse fault and it works. Then, I tried to take the same geometry and make it 2D cutting only one slide, the mdiurface (in LaGriT pset/attribute command) and I can see the result using the GMV viewer. However, when I run PyLith using the MeshIOlagrit reader, I have this error in reading the mesh:

bash-4.4$ pylith step01.cfg

/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/lib/python2.7/site-packages/pylith/utils/PetscManager.py:64:initialize
– petsc(info)
– Initialized PETSc.

/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/lib/python2.7/site-packages/pylith/apps/PyLithApp.py:103:main
– pylithapp(info)
– Running on 1 process(es).

/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/lib/python2.7/site-packages/pylith/meshio/MeshIOObj.py:55:read
– meshiolagrit(info)
– Reading finite-element mesh
[0]PETSC ERROR: --------------------- Error Message --------------------------------------------------------------
[0]PETSC ERROR: Argument out of range
[0]PETSC ERROR: Cone size 2 not supported for dimension 2
[0]PETSC ERROR: See http://www.mcs.anl.gov/petsc/documentation/faq.html for trouble shooting.
[0]PETSC ERROR: Petsc Development GIT revision: v3.7.6-4826-gd686aaf GIT Date: 2017-08-03 14:01:44 -0500
[0]PETSC ERROR: /home/student/simone/pylith/pylith-2.2.1-linux-x86_64/bin/mpinemesis on a arch-pylith named ig-d06625.ig.utexas.edu by simone Sat Dec 22 09:31:00 2018
[0]PETSC ERROR: Configure options --prefix=/home/brad/pylith-binary/dist --with-c2html=0 --with-x=0 --with-clanguage=C --with-mpicompilers=1 --with-debugging=0 --with-shared-libraries=1 --with-64-bit-points=1 --with-large-file-io=1 --download-chaco=1 --download-ml=1 --download-f2cblaslapack=1 --with-hwloc=0 --with-ssl=0 --with-x=0 --with-c2html=0 --with-lgrind=0 --with-hdf5=1 --with-hdf5-dir=/home/brad/pylith-binary/dist --with-zlib=1 --LIBS=-lz --with-fc=0 CPPFLAGS="-I/home/brad/pylith-binary/dist/include " LDFLAGS="-L/home/brad/pylith-binary/dist/lib -L/home/brad/pylith-binary/dist/lib64 " CFLAGS="-g -O2" CXXFLAGS="-g -O2 -DMPICH_IGNORE_CXX_SEEK" FCFLAGS= PETSC_DIR=/home/brad/pylith-binary/build/petsc-pylith PETSC_ARCH=arch-pylith
[0]PETSC ERROR: #1 DMPlexGetRawFaces_Internal() line 86 in /home/brad/pylith-binary/build/petsc-pylith/src/dm/impls/plex/plexinterpolate.c
[0]PETSC ERROR: #2 DMPlexGetFaces_Internal() line 17 in /home/brad/pylith-binary/build/petsc-pylith/src/dm/impls/plex/plexinterpolate.c
[0]PETSC ERROR: #3 DMPlexInterpolateFaces_Internal() line 163 in /home/brad/pylith-binary/build/petsc-pylith/src/dm/impls/plex/plexinterpolate.c
[0]PETSC ERROR: #4 DMPlexInterpolate() line 523 in /home/brad/pylith-binary/build/petsc-pylith/src/dm/impls/plex/plexinterpolate.c
[0]PETSC ERROR: #5 DMPlexCreateFromCellList() line 2617 in /home/brad/pylith-binary/build/petsc-pylith/src/dm/impls/plex/plexcreate.c
[0]PETSC ERROR: #6 static void pylith::meshio::MeshBuilder::buildMesh(pylith::topology::Mesh*, pylith::scalar_array*, int, int, const int_array&, int, int, int, bool, bool)() line 82 in …/…/…/pylith-2.2.1/libsrc/pylith/meshio/MeshBuilder.cc
Fatal error. Calling MPI_Abort() to abort PyLith application.
Traceback (most recent call last):
File “/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/lib/python2.7/site-packages/pylith/apps/PetscApplication.py”, line 74, in onComputeNodes
self.main(*args, **kwds)
File “/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/lib/python2.7/site-packages/pylith/apps/PyLithApp.py”, line 115, in main
mesh = self.mesher.create(self.problem.normalizer, interfaces)
File “/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/lib/python2.7/site-packages/pylith/topology/MeshImporter.py”, line 100, in create
mesh = self.reader.read(self.debug, self.interpolate)
File “/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/lib/python2.7/site-packages/pylith/meshio/MeshIOObj.py”, line 71, in read
ModuleMeshIO.read(self, mesh)
File “/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/lib/python2.7/site-packages/pylith/meshio/meshio.py”, line 86, in read
def read(self, *args): return _meshio.MeshIO_read(self, *args)
RuntimeError: Error detected while in PETSc function.
application called MPI_Abort(MPI_COMM_WORLD, -1) - process 0
/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/bin/nemesis: mpirun: exit 255
/home/student/simone/pylith/pylith-2.2.1-linux-x86_64/bin/pylith: /home/student/simone/pylith/pylith-2.2.1-linux-x86_64/bin/nemesis: exit 1
bash-4.4$

Thank you so much, have a wonderful day.
Happy holidays.
Best regards,
Simone


#2

I suspect the topology of the mesh does not conform to what we expect. Did you verify there are no coincident nodes? Also the buried edges of the fault must be marked as a pset and identified in the .cfg file. This second item does not appear in the example. See Section 6.4.2 of the PyLith v2.2.1 manual, especially Figures 6.3 and 6.4.

Sorry for the delay in responding caused by the government shutdown in the US.


#3

Good afternoon Brad,

Thank you so much. I am so sorry for the late reply.
I have verified that there are no coincident nodes, but I did not mark the fault buried edge as a pset.
Thanks, have a wonderful day and weekend.

Best regards,
Simone