Candi installation


I tried to install ASPECT using the manual (local installation) and I downloaded candi (git clone GitHub - dealii/candi: candi - (Compile & Install) - Downloads, configures, builds and install). In the execution process, I always get the same error which is;

CMake Error at cmake/tribits/core/package_arch/TribitsProcessEnabledTpl.cmake:127 (MESSAGE):
Call Stack (most recent call first):
cmake/tribits/core/package_arch/TribitsGlobalMacros.cmake:1614 (TRIBITS_PROCESS_ENABLED_TPL)
cmake/tribits/core/package_arch/TribitsProjectImpl.cmake:202 (TRIBITS_PROCESS_ENABLED_TPLS)
cmake/tribits/core/package_arch/TribitsProject.cmake:93 (TRIBITS_PROJECT_IMPL)
CMakeLists.txt:93 (TRIBITS_PROJECT)
– Configuring incomplete, errors occurred!
See also “/home1/08331/bodurom/dealii-candi/tmp/build/trilinos-release-12-10-1/CMakeFiles/CMakeOutput.log”.
Failure with exit status: 1
Exit message: There was a problem configuring trilinos 12-18-1.

Also, I tried to change the trillions.package (candi/deal.II-toolchain/packages/trilinos.package). I commanded,


and uncommanded,

CHECKSUM="667333dbd7c0f031d47d7c5511fd0810 40f28628b63310f9bd17c26d9ebe32b1

It gives the same error. Do you have any idea about this error?

Hi Bodurom,

Thank you for posting to the forum! The issue is that Trilinos is not able to find the required blas libraries.

Can you describe the operating you are using and what packages have been installed already? In particular, what BLAS/LAPACK libraries have been built. All of the required libraries are normally readily available for installation on most systems.



Hi Dr. Naliboff,

When I’m posting that question, I didn’t realize that it is another instruction for stampede2 users. I tried that manual for installing aspect. But now I’m getting a different error. When trying to compiling ASPECT (with the last command ‘make -j48’), it gives me Unity errors. Are these unity boxes crucial for the ASPECT? Is there any chance to install the program without these boxes?


Hi Omer,

No problem at all, we should add a note in the manual about the compiling instructions for specific computers on the wiki.

A quick note for others - Omer is compiling on Stampede2, and the instructions for this were updated yesterday after he identified an issue with the current version of OpenBlas used by candi (related to GNU compiler versions on Stampede2).

Omer - I was able to compile the master version of ASPECT yesterday on Stampede2 following the instructions above. However, I realized I did not specifically test aspect 2.3.

Can you try compiling the master version with your current deal.II build? Simply clone the ASPECT repository and then compile without switching to 2.3.

Can you also try recompiling version 2.3 with the unity build option turned off? To do this, go into the build directory and modify CMakeCache.txt so that ASPECT_UNITY_BUILD:BOOL=OFF. You will need to run make clean first.


Hello Dr. Naliboff,

I deleted all your dealii/ASPECT folders and restarted the process from scratch by following the updated instructions. It worked, I finally can install the ASPECT.

Thanks for your help,
Best regards,