A problem occurred when installing aspect in docker(windows11)

Dear all,

Run aspect in docker images ,I need to run a new container.

What’s wrong with the setup .

The container does not run correctly

@leisurely Can you describe what “does not run correctly” means? What is the error message you get?

Hi W.

Thanks for your response

After setting up the container,click Start and the status of the software is still Exited


I’m afraid someone with more docker experience will have to help :frowning:

Hi Wolfgang

I still want to thank you


Dear all
This problem can be solved by Install an older version of docker(4.12.0)
But the new version of docker still has this problem
I don’t know how to solve it

Can you try opening a terminal window instead and running “docker run” as described in Running ASPECT models — ASPECT 2.5.0-pre ?
I am curious if this will give an error message.

I just tried with the latest docker version under Windows and the container runs without issues when opening it through the command line. I could not figure out how to run it using the graphical user interface as the container immediately exits.

Thanks for your reply, this is the same situation I encountered.

Maybe this is a bug in the new version of docker