Why my output particule file is writing without any point?


I’m having an issue for some day with Aspect.
I’m doing a run with particles and thermal convection . We have a 2D box of 1 in y and 3.5 in x, and my particles are located in a box of 0.4 * 0.4 in the middle of my simulation. We put 10^6 particles in it, and we also try with 10^5, but in both cases, the output file doesn’t write well . Some of my vtu files are 500 bytes, instead of the usual 20 Mb (or near it). When we look at it, there just no point written in it !

We make several attempt to solve it (make a bigger square for the particles, to reduce the concentration, or make less particles) , but that didn’t work. Other configuration, like a checkerboard ( particles en top left and bottom right), or a band ( on every x, but only for z in 0.4 and 0.6), works.

So, we don’t understand what doesn’t work there.

(If you need more informations about my work, we try to simulate the earth’s mantle, with Ra=1e7. Feel free to ask more informations).

So I’m coming here to ask for your help, if you have any idea of what’s going on.

Thank you,


@Emilie Are you running in parallel? In that case, it is of course possible that some processors have no particles at all, and the output file should be small. Other processors may have lot of particles and be large.

In general, though, it’s hard to tell. Can you create a .prm file that shows the issue and that is easy to share (i.e., does not depend on other external files)?


Dear Emilie,

I agree with @bangerth, to help you we would need an input file that reproduces the problem. In particular it would be important to know what particle generator you use.
Another question I had was: The particles should not move in time step zero, so if you look at the very first particle output, they should be in the location you defined. Does the output from this step 0 already have no particles?

You can also set the parameter
set Number of grouped files = 1
in the Particles section so that you will only get on particles file per time step.



I will try to make you the file as soon as possible. Do you want the prm file I used to launch aspect ?

I had sometimes no particles in the first file (the 00000). Each file are divided on 8 sub-files, surely because I work on 8 cores. It’s only some of them which don’t have particles in it. Paraview can visualize them, but my file on jupyter notebook can’t work with file without particles.
Can I just delete them and work on the file with particles, or it will degrade my result ?

This idea about only one particle file seems to be a really good idea ! I will try it !



@Emilie Yes, the .prm file is what we’re looking for.