When I run the example with pylith v2.2, occuring the error

error is >/usr/bin/env: ‘nemesis’: No such file or directory

nemesis is a PyLith provided parallel processing aware wrapper around Python. You need to setup your environment so that nemesis and the other PyLith software is available. For the PyLith binary packages, this is done by running source setup.sh in the top-level PyLith directory. Refer to the PyLith installation instructions for more information.

I run source setup.sh at the top of the pylith directory, and I get an error when I run the example. I don’t know why, it’s weird

If you need additional help, please provide a description of your operating system, the directory where you installed PyLith, and show complete details for every command you are running and the resulting output, beginning with source setup.sh.

My operate system is WSL, and installation path is /mnt/f/pylith-2.2.1-linux-x86_64/pylith-2.2.1-linux-x86_64,

However, when I run the pylith v4.0, pylith is ok.

PyLith v2 is uses Python 2 whereas PyLith v3 and later use Python 3. We provide the appropriate Python in the Linux binary. I suspect there is a conflict with your environment when you use PyLith v2.2. I recommend setting PATH to only system libraries and unsetting LD_LIBRARY_PATH and PYTHONPATH (see below) before running source setup.sh.


I’m using Python 2.7 to run pylith2.2 and have set it up as you recommended, but I still get the same error!