Running a forward simulation using my own slip model returns an error


When attempting to run a forward simulation, pylith (v2.2.2) displays the following error relating to reading the spatialdb file for slip after I run the command ‘pylith eqsim.cfg’ in terminal:

I am confused as to why its experiencing this error. I ran the example provided without any issues. I use the exact same formatting as in the example for 2D reverse faulting’s eqsims. The main difference is this is being run in 3D. I cannot use a newer version of pylith as the mesh I am using is written for this version.

I have attached a .zip file showing what the spatial db file looks like. (628 Bytes)

There are a few couple with the spatial database.

  1. For a 3D problem, you need to specify all 3 components of fault motion (left-lateral-slip, reverse-slip, and fault-opening).
  2. The number of items should be the same for value-names and value-units and match num-values`.

Meshes constructed for PyLith v2 will work with v3; however, the .cfg files must be updated.

I just tried specifying all 3 components and ensuring the number of items for value-names, value-units = num-values = 3 (see attached .zip).

I get the following error:

I re ran it and got the same error. (560 Bytes)

Your header indicates you have 24 points (num-locs=24) but you only provide 18 points.