Mpirun noticed that process rank 2 with PID 0 on node dealvm exited on signal 9 (Killed)


I am running a simple 3D case with 20 multiply 20 multiply 33 elements (i.e., X, Y, Z repetitions are 20, 20, and 33, respectively; no mesh refinement is applied at all.). This job is submitted by typing “mpirun -np 8 …/aspect ****.prm” in the terminal. Later, the system gave the following feedback:

mpirun noticed that process rank 2 with PID 0 on node dealvm exited on signal 9 (Killed).

However, if the number of elements is reduced to 10 multiply 10 multiply 3, ASPECT can give me the right output. In fact, the ideal case should have at least 100 multiply 100 multiply 33 elements. What I have tested now is far from that.

What’s wrong with my settings? Have you met similar issue? Perhaps this issue arises when we run ASPECT on a virtual machine. Right?

Best regards,

Hi Shaozhuo,

Thank you for posting to the forum!

What is likely happening is that you are running out of available memory on the virtual machine when you run the larger (20x20x33) model.

How much available RAM do you have on the computer? You can adjust the amount of RAM allocated to the virtual machine (prior to starting it) by clicking on the virtual machine name and then selecting settings (see attached image). If possible, I would start by increasing the amount of RAM allocated to the virtual machine. However, don’t allocate too much as this may cause your computer to freeze.

A less memory-intensive alternative to the virtual machine would be to install ASPECT via docker (see ASPECT manual).

May I ask what type of operating system your computer uses? As long as the OS is reasonably up to date, you should be able to natively install dealii/ASPECT on linux, OSX, or windows systems.


Hello John,

Thanks for your warm-hearted help!

Indeed, your advice gives the right solution. Now the modeling can continue when the RAM was increased to 100,000 MB, almost close to the maximum RAM available (129024 MB).

The operation system is Linux. I tried to install dealii/aspect two months ago but failed. Instead I used the virtual machine.

My workstation has only 32 cores available, which is still not enough for modeling large problems with more than 1e5 elements and millions of unknowns.


Hi Shaozhuo,

Great to hear that worked!

May I ask what the error was in compiling deal.II on your system, as well as what version of linux you are using? We may be able to sort out the issue. The candi installer for deal.II (see ASPECT manual) is normally fairly straightforward as long as the necessary basic libraries are installed.

Also, can I ask some general questions about the setup of your model? If you are using free-slip or no-slip boundaries without mesh deformation, you can use the relatively new GMG stokes solver that substantially reduces memory requirements and speeds up the Stokes solves.