KeyError: Unable to open object(bad symbol table node signature)

Dear Pylith team,

I have encountered the following mistake. I don’t know how to solve it. Any suggestions or help will be greatly appreciated.

Nick

This looks like a corrupt HDF5 file. It looks like this error occurs when PyLith is trying to generate the Xdmf file. Try using h5dump or h5info on the HDF5 output files to see if those utilities can read the files. If things look okay, you can use pylith_xdmf to try to generate the missing Xdmf files. If the HDF5 utilities can’t read the HDF5 files, then they likely got corrupted and the only solution is to rerun the simulation.

Hi Brad,

Thank you for your fast response.
I tried to use h5dump on the HDF5 output files. The result is generated into a TXT file. Things look okey. I tried to use pylith_xdmf but failed. Could you tell me exactly how to use pylith_xdmf? Finally, I completely followed the statements in the example to write the cfg file, why can’t I generate the Xdmf file?
The h5 file and txt file are attached below:

Nick

Dear Nick,

The pylith_genxdmf utility creates a Xdmf file for the HDF5 file you sent (I just tried it). This utility is located in the same directory as the pylith executable, so it should be in your PATH. If you are in the directory where your domain.h5 file is located, you can do:

pylith_genxdmf -f domain.h5

I am not sure why PyLith was unable to generate this file initially.

Cheers,
Charles

Dear Charles,

According to the method you said, I succeeded in getting the Xdmf file. Cheers!

Nick