DEAL II installation

Soooo I’m trying to install ASPECT on a cluster which is a Linux Centos 7.6, and first I need to install deal II via candi. Everything is obtained by modules (not access to yum), so I need to choose the correct modules (and hope that they have been compiled with the same compilers).

I loaded the modules for GCC and openmpi (I tried both GCC 8.1 and GCC 10.1) and for cmake.
But I got a very strange error: the system does not find a C compiler or a CXX compiler (The C compiler identification is unknown) and then tries to look for an intel compiler…

I’m not sure what I’ve done wrong here.
Any idea? (before I open an issue in



Project: deal.II-toolchain
Platform: deal.II-toolchain/platforms/supported/centos7.platform

Loading dealii-prepare
Fetching opencascade 0.18.2
Verifying OCE-0.18.2.tar.gz
OCE-0.18.2.tar.gz: OK
OCE-0.18.2.tar.gz already downloaded and verified.
Unpacking OCE-0.18.2.tar.gz
applying patch for missing xlocale.h for glibc v2.26 and above
patching file src/Standard/Standard_CLocaleSentry.hxx
Building opencascade 0.18.2
– The C compiler identification is unknown
– The CXX compiler identification is unknown
– Detecting C compiler ABI info
– Detecting C compiler ABI info - failed
– Check for working C compiler: /trinity/shared/apps/cv-standard/openmpi/ucx/icc20/4.0.3_ib/bin/mpicc
– Check for working C compiler: /trinity/shared/apps/cv-standard/openmpi/ucx/icc20/4.0.3_ib/bin/mpicc - broken
CMake Error at /trinity/shared/apps/cv-standard/cmake/3.18.2/share/cmake-3.18/Modules/CMakeTestCCompiler.cmake:66 (message):
The C compiler


is not able to compile a simple test program.

It fails with the following output:

Change Dir: /home/LPGN/lasbleis-m/deal.ii-candi/tmp/build/oce-OCE-0.18.2/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/gmake cmTC_a8144/fast && /usr/bin/gmake  -f CMakeFiles/cmTC_a8144.dir/build.make CMakeFiles/cmTC_a8144.dir/build
gmake[1]: Entering directory `/home/LPGN/lasbleis-m/deal.ii-candi/tmp/build/oce-OCE-0.18.2/CMakeFiles/CMakeTmp'
Building C object CMakeFiles/cmTC_a8144.dir/testCCompiler.c.o
/trinity/shared/apps/cv-standard/openmpi/ucx/icc20/4.0.3_ib/bin/mpicc    -o CMakeFiles/cmTC_a8144.dir/testCCompiler.c.o -c /home/LPGN/lasbleis-m/deal.ii-candi/tmp/build/oce-OCE-0.18.2/CMakeFiles/CMakeTmp/testCCompiler.c
/trinity/shared/apps/cv-standard/openmpi/ucx/icc20/4.0.3_ib/bin/mpicc: error while loading shared libraries: cannot open shared object file: No such file or directory
gmake[1]: *** [CMakeFiles/cmTC_a8144.dir/testCCompiler.c.o] Error 127
gmake[1]: Leaving directory `/home/LPGN/lasbleis-m/deal.ii-candi/tmp/build/oce-OCE-0.18.2/CMakeFiles/CMakeTmp'
gmake: *** [cmTC_a8144/fast] Error 2

CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
CMakeLists.txt:20 (project)

– Configuring incomplete, errors occurred!
See also “/home/LPGN/lasbleis-m/deal.ii-candi/tmp/build/oce-OCE-0.18.2/CMakeFiles/CMakeOutput.log”.
See also “/home/LPGN/lasbleis-m/deal.ii-candi/tmp/build/oce-OCE-0.18.2/CMakeFiles/CMakeError.log”.
Failure with exit status: 1
Exit message: There was a problem configuring opencascade 0.18.2.

Hi Marine,

It looks like the error is with libimf, which is the intel math library. Do you know if any of the libraries being used were built using the intel compilers?

This may not be the issue here, but in the past I’ve run into issues on clusters where both gnu and intel “modules” are loaded (i.e., candi can find them in path). The solution was to make sure all of the intel modules are not loaded. The exact issue/solution may be more complicated in this case …


Soooo, I should delete this, or keep it in case someone else does the same mistake :wink:
I accidentally started the compilation with another compiler, and so the system tried to stick to this one.
I deleted all the folder where I was doing the candi process, started from fresh, and now it’s compiling.
I had an error for the compilation of deal II, so I may need to come back here. But it may have been because of an error on the server because I was compiling with several cores. I switched back to 1 core for compiling deal II, and it’s taking forever, but I’ll have to wait tomorrow to see the end result and the possible error.

Hi Marine,

My vote would definitely be to keep this discussion in the archives, as someone may encounter the exact same issues down the road. This has happened to me on more than one occasion as well :wink:

Did everything work with the fresh installation?


It took a while to compile everything, but it worked. I am wondering about adding a new “contributed” platform for this particular cluster. It’s a CentOS 7, so it was “recognized” by candi, but with incorrect parameters. Since we do not have access to yum, but only modules, I had to find the correct modules, etc.
Everything was compiled with gcc 8.1, and cmake 3.10 (the CentOS candi config file was trying to install another cmake, which was not possible on this particular platform and advized by the admin to use the existing cmake versions).
For people who may have access to this particular platform (in France): it’s the CCIPL doc:main [Documentation Publique CCIPL]

We haven’t tried to run ASPECT yet, but everything is compiled successfully, so I’m quite confident it’s working :slight_smile: