Why can't I use the "ascii data layered" option?

Hello folks,

I am testing the simple example ./tests/run ascii_data_layered_initial_temperature_3d_box.prm which shows how to define the initial temperature from temperatures specified on layered surfaces. The key settings are as follows:

subsection Initial temperature model
set Model name = ascii data layered
subsection Ascii data model
set Data directory = $ASPECT_SOURCE_DIR/data/initial-temperature/ascii-data/test/
set Data file names = initial_isotherm_1000K_box_3d.txt, initial_isotherm_500K_box_3d.txt
set Interpolation scheme = linear

No matter how I tried, it can’t run through. ASPECT outputs the following message:

– This is ASPECT, the Advanced Solver for Problems in Earth’s ConvecTion.
– . version 2.1.0-pre (master, 0d0f2be)
– . using deal.II 9.0.0
– . using Trilinos 12.10.1
– . using p4est 2.0.0
– . running in OPTIMIZED mode
– . running with 1 MPI process
– How to cite ASPECT: https://aspect.geodynamics.org/cite.html

Line <28> of file <input string>:
The entry value 
    ascii data layered
for the entry named
    Model name
does not match the given pattern:
    [Selection S40RTS perturbation|SAVANI perturbation|adiabatic|adiabatic boundary|ascii data|function|harmonic perturbation|inclusion shape perturbation|mandelbox|perturbed box|polar box|spherical gaussian perturbation|spherical hexagonal perturbation|unspecified ]

ERROR: Uncaught exception in MPI_InitFinalize on proc 0. Skipping MPI_Finalize() to avoid a deadlock.

Exception ‘dealii::ExcMessage (“Invalid input parameter file.”)’ on rank 0 on processing:

An error occurred in line <420> of file </home/geodynamics/aspect/source/main.cc> in function
void parse_parameters(const string&, dealii::ParameterHandler&)
The violated condition was:
Additional information:
Invalid input parameter file.


Primary job terminated normally, but 1 process returned
a non-zero exit code… Per user-direction, the job has been aborted.

mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

Process name: [[57922,1],0]
Exit code: 1

Why? Weird! The option “ascii data layered” can’t be used!

Best regards,

Dear SZ,

Have you tried running this prm with a more recent version of ASPECT? You’re using a version that was released only two days after I introduced that plugin, and there may have been problems with it at that point (although I don’t remember that being the case).

Best wishes,

Hello Bob,

Indeed, the issue arose because an old version of ASPECT was used.

Thanks very much!