Problem with running 3D continental extension models

Hi @egg_wang,

Thanks for posting to the forum and sorry it has taken me some time to get to this question. I saw it when it was originally posted, but did not have time until now to go properly go through and think about the setup and reported issues.

Some responses below:

1.The result cannot converge when the nonlinear solver tolerance or linear Stokes solver tolerance is small(<=10^-3).

My experience is that for this type of complex setup, the GMG solver has trouble converging when the mix/max viscosity contrasts is more than 4-5 orders of magnitude. For rifting problems, it is often the lower viscosity in the asthenosphere (1e18 or 1e19 Pa s) that seems to present the most problems, rather than the upper viscosity limit.

To proceed, I suggest trying the following:

  1. Decrease the minimum viscosity to 1e20 Pas and the maximum viscosity to 1e24 Pa s.
  2. Decrease the nonlinear solver tolerance to 1e-4 or 1e-5 (the stricter, the better)
  3. Switch the nonlinear solver scheme to single Advection, iterated Stokes (see this forum post for more info).
  4. Decrease the linear solver tolerance to 1e-7
  5. Increasing the CFL value to 0.25 or 0.5

Run a model using the changes above and see if it produces more stable convergence behavior (it should).

From there, try expanding the min-max viscosity range (ex: 1e20-1e25, 1e19-1e24, etc) to see if you can still achieve stable convergence behavior with the same settings.

2.After increasing the tolerance, initially, each step required only around ten iterations. However, after computing for several million years, even after a full 100 iterations, the convergence doesn’t reach 10^-2, making the computation very slow.

I think this is due to both the constraints outlined above, and a compound effect where the system is not being solved accurately enough through time due the high non-linear solver tolerance.

  1. The model cannot operate normally; it interrupts and displays an out-of-memory error after running for two to three hours.

I’m not sure what is happening here either, but let’s start with the passive model adjustments first.

Another general suggestion - if you have not already done so, try simplifying the material settings such that the viscosity in constant everywhere (min viscosity = max viscosity), and use that simplified setup to make sure the boundary and initial conditions (temperature, composition) are giving the expected results.

Can you try the suggestions above and report back?