Installing deal.ii 9.2.0 with candi version 9.2.0-r1

Hi, I cloned the most recent release of candi yesterday and run into the following error when trying install deall.ii v. 9.2.0 on Ubuntu 18.04 LTS:

Now to install the libraries do:
make PETSC_DIR=/home/egpuckett/WORKSPACE/deal.ii-9.2.0/tmp/build/petsc-lite-3.13.1 PETSC_ARCH=arch-linux2-c-opt install
Verifying slepc-3.13.2.tar.gz
slepc-3.13.2.tar.gz: OK
Unpacking slepc-3.13.2.tar.gz
Building slepc 3.13.2
Checking environment… done
Checking PETSc installation…
ERROR: Unable to link with PETSc
ERROR: See “installed-arch-linux2-c-opt/lib/slepc/conf/configure.log” file for details
Failure with exit status: 1
Exit message: slepc ./configure failed
(dealii-9.2) $

I recall a short mention, either at the Tectonics Tutorial or on this forum that PETSc was no longer supported. Was that just in ASPECT or also deal.ii (or would it matter …)

Is this a bug in candi version 9.2.0-r1 or am I doing something wrong? I have a work around courtesy of Mack Gregory; namely,

cd into that PREFIX_PATH/tmp/src, and run


and then restart candi

But I have never had to do anything like this with earlier releases of deal.ii and candi.

Can you please disable (comment out) PETSc and SLEPc in the candi.cfg? I will try to see if I get the same error here.

Yes, of course!

Timo, As I’m sure you already knew, that solved the problem:

– Installing: /home/egpuckett/WORKSPACE/deal.ii-9.2.0/deal.II-v9.2.0/share/deal.II/scripts/

dealii.git has now been installed in


To update your environment variables, use the created modulefile:


If you are not using modules, execute the following command instead:

source /home/egpuckett/WORKSPACE/deal.ii-9.2.0/configuration/deal.II-v9.2.0

To export environment variables for all installed libraries execute:

source /home/egpuckett/WORKSPACE/deal.ii-9.2.0/configuration/

Build finished in 2828 seconds.

Summary of timings:

dealii-prepare: 0 s
opencascade: 0 s
parmetis: 0 s
hdf5: 0 s
p4est: 0 s
trilinos: 0 s
dealii: 2823 s